		MISP CSPro Manual | Women’s Refugee Commission
	MISP CSPro Manual | Women’s Refugee Commission
[bookmark: _Toc371422577][bookmark: _Toc371496755][bookmark: _Toc371497222][bookmark: _Toc371497275][bookmark: _Toc371499001][bookmark: _Toc371500982][bookmark: _Toc371610500][bookmark: _Toc371610550][bookmark: _Toc371610602][bookmark: _Toc409820696][bookmark: _Toc410194572][bookmark: _Toc422483880][bookmark: _Toc422556022][bookmark: _Toc369606647][bookmark: _GoBack][bookmark: _Toc328137425][image: ]
For the MISP survey, automated tools for electronic data collection have been developed using the Census and Survey Processing System (CSPro) software.  This manual serves as step by step instructions for using the MISP CSPro electronic questionnaires.  The following topics are covered in this manual:
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[bookmark: _Toc454464196]I. Introduction to CSPro
CSPro is a software package for entry, editing, tabulation, and dissemination of census and survey data.  CSPro lets you create, modify, and run data entry, batch editing, and tabulation applications from a single, integrated development environment.  The data are stored in text files described by data dictionaries.  CSPro was developed jointly by the U.S. Census Bureau, Macro International, and Serpro, SA, with major funding from the U.S. Agency for International Development. 
CSPro is not intended to provide database management capabilities; however, the data generated and/or manipulated by a CSPro application may be imported into a database system.  While CSPro provides some tabulation capabilities, it is not intended to replace more sophisticated statistical analysis software such as SAS, SPSS, Stata, etc.  In addition, even though CSPro includes a module for generating thematic maps, it cannot be considered a geographical information system [GIS], as the maps cannot show the multiple layers available in a true geographical information system. 
CSPro is in the public domain. It is available at no cost and may be freely distributed.  It is available for download at http://www.census.gov/population/international/software/cspro/csprodownload.html
[bookmark: _Toc322946984][bookmark: _Toc322947056][bookmark: _Toc327430221][bookmark: _Toc327431282][bookmark: _Toc328137426][bookmark: _Toc454464197]CSPro capabilities
[bookmark: _Toc295805566][bookmark: _Toc297832135][bookmark: _Toc322946985][bookmark: _Toc322947057][bookmark: _Toc327430222][bookmark: _Toc327431283][bookmark: _Toc371496758]Enter, modify, and verify data
CSPro users can create data entry forms (screens) for data capture.  The application designer has full control over form layout.  CSPro supports rosters, consistency checks and skip patterns of unlimited complexity, user-defined messages and menus, multiple lookup files, and produces operator statistics. CSPro data entry applications run on Windows and Android devices (The Android app for the interviewing module can be downloaded from Google Play. For Windows, the same installation package is used for the development process as well as for the interviewing).  The version used for Android is also capable of synchronizing with Dropbox, or to upload files using ftp.
Once a case has been completely entered, the operator can modify any part of the existing data and can add or remove information (subject to application constraints).  
CSPro supports both dependent and independent verification (double keying) to ensure the accuracy of the data entry operation.  Using independent verification, operators can key data into separate data files and use CSPro utilities to compare them.  Using dependent verification, operators can key data a second time and have CSPro immediately compare it to what was keyed the first time on a field by field basis.
[bookmark: _Toc295805567][bookmark: _Toc297832136][bookmark: _Toc322946986][bookmark: _Toc322947058][bookmark: _Toc327430223][bookmark: _Toc327431284][bookmark: _Toc371496759]Process census or survey data
Given an existing data file, a user can develop a CSPro application that will examine the file for inconsistencies, structural defects, or other errors.  CSPro permits the user to generate detailed reports on all errors found; the user may also create sub-files from the original data, and may use multiple look-up files during the validation and/or report-generation process.
[bookmark: _Toc295805568][bookmark: _Toc297832137][bookmark: _Toc322946987][bookmark: _Toc322947059][bookmark: _Toc327430224][bookmark: _Toc327431285][bookmark: _Toc371496760]Manipulate data files 
CSPro permits the user to re-structure existing data files and to create subsets of data in separate files.  New files may also be created by merging two or more case-related files.  Data files in software-specific formats may be created for import into spreadsheets and some statistical packages.
[bookmark: _Toc295805569][bookmark: _Toc297832138][bookmark: _Toc322946988][bookmark: _Toc322947060][bookmark: _Toc327430225][bookmark: _Toc327431286][bookmark: _Toc371496761]Tabulate data 
The user can create an application to produce frequency distributions or cross-tabulations using two to four variables.  Results can be displayed either globally (for the totality of the data file) or according to one or more elements of the geographic hierarchy.  Tabulations may show only percentages, or percentages in conjunction with counts; data may be weighted or un-weighted.
[bookmark: _Toc295805570][bookmark: _Toc297832139][bookmark: _Toc322946989][bookmark: _Toc322947061][bookmark: _Toc327430226][bookmark: _Toc327431287][bookmark: _Toc371496762]Create thematic maps
If computerized maps are available for the relevant geographic areas, CSPro may be used to generate cross-tabulations whose results can be joined to the map files to produce thematic maps for display of information.  Thematic map display parameters permit a high degree of customization in the presentation of these data.
[bookmark: _Toc295805571][bookmark: _Toc297832140][bookmark: _Toc322946990][bookmark: _Toc322947062][bookmark: _Toc327430227][bookmark: _Toc327431288][bookmark: _Toc371496763]Use and share external files 
When a data file is to be used by more than one person, a CSPro dictionary can be created and distributed among users of the data to facilitate access.  The different needs of individual users can be catered to by including multiple value sets for variables, so that each user’s requirements are met.
[bookmark: _Toc295805572][bookmark: _Toc297832141][bookmark: _Toc322946991][bookmark: _Toc322947063][bookmark: _Toc327430228][bookmark: _Toc327431289][bookmark: _Toc371496764]Examine data files 
CSPro provides language elements that will permit the specification of logic to carry out a detailed examination of a data file.  Elements of the file may be tested against other elements of the same file or against elements of one or more other files, and the user may generate reports showing the results of the examination.  CSPro also provides a tool for comparing the contents of two data files.  This tool will generate a detailed report to the user documenting any differences found.
[bookmark: _Toc295805573][bookmark: _Toc297832142][bookmark: _Toc322946992][bookmark: _Toc322947064][bookmark: _Toc327430229][bookmark: _Toc327431290][bookmark: _Toc371496765]Interactive editing 
CSPro language elements can be used to construct a series of tests to be carried out on a case-by-case basis using the CSEntry module.  Whether adding a new case or modifying an existing case, CSPro instructions permit interactive editing and correction of data elements.  If the user desires, a report on editing activity may be generated and saved for printing after the session is completed.
[bookmark: _Toc295805574][bookmark: _Toc297832143][bookmark: _Toc322946993][bookmark: _Toc322947065][bookmark: _Toc327430230][bookmark: _Toc327431291][bookmark: _Toc371496766]Examine results of editing 
Whether the user is carrying out interactive or batch editing, the CSPro language permits the preparation of reports with detailed information on cases tested, errors found, and errors corrected.  These reports are written to disk in ASCII-text format and may be viewed with any text viewer, such as CSPro’s utility Text Viewer, and may also be printed.  They provide documentation of work carried out and permit analysis of types and frequency of errors.
[bookmark: _Toc454464198]CSPro for MISP
[bookmark: _Toc370471954]A set of standard CSPro applications have been developed for the Minimum Initial Service Package (MISP) for Reproductive Health Process Evaluation Toolkit.  These applications serve as a data entry interface and can be adapted based on any changes made to the core MISP questionnaires.   This document provides instructions on how to adapt the standard MISP CSPro application at country level, as well as how to run the CSPro application for data entry.  For complete documentation and tutorials on how to use CSPro more generally, please refer to the US Census Bureau website.
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II. Technical information
[bookmark: _Toc293999327][bookmark: _Toc295805575][bookmark: _Toc297832144][bookmark: _Toc322946994][bookmark: _Toc328137429][bookmark: _Toc454464200]Hardware and software requirements
The following requirements are necessary in order to use CSPro for data entry: 
CSPro 6.3 runs under Windows XP, Vista, 7, 8, and 10.  It does not run under Windows 8 RT.
RECOMMENDED CONFIGURATION FOR QUESTIONNAIRE DEVELOPMENT AND DATA ENTRY
· Desktop or laptop computer
· Pentium Processor
· 512 MB of Ram
· SVGA monitor
· Mouse or touchscreen
· 100MB of free hard drive space
· Microsoft Windows XP, Vista, 7, 8, or 10. (NB: CSPro does not run on Windows 8 RT)
[bookmark: _Toc293999328][bookmark: _Toc295805578][bookmark: _Toc297832147][bookmark: _Toc322946995][bookmark: _Toc328137430][bookmark: _Toc454464201][bookmark: _Toc290901873][bookmark: _Toc295805579]Software installation
[bookmark: _Toc371496772]Install CSPro on a computer/laptop
The following is based on a Windows 10 setup. Your steps may vary if using a different operating system. 
Download the CSPro application by browsing to the following link and clicking on CSPro 6.3 installation package: http://www.census.gov/population/international/software/cspro/csprodownload.html
Install CSPro 6.3 to your computer by double-clicking on cspro63.exe (the last digit of the version number might change as new releases are published). This will start the installation wizard.  Follow the prompts to begin installation and accept the Terms of Service.
CSPro allows you to select which components of the system you want to install. During the installation you will see the following component screen: 
[image: ]
You have the following choices: 
· CSPro (all components): Select this if you plan to develop applications. 
· Data Entry Operator (only): Select this if you are installing a data entry application on a production machine. The operator will be able to run an already-created data entry application, but will not be able to make any changes to it. The Data Entry, Compare Data, Text Viewer, and Table Viewer components are installed. 
· The rest of the default settings for the installation are OK, so just click “next” until finished.
[bookmark: _Toc322947073][bookmark: _Toc327430238][bookmark: _Toc327431299][bookmark: _Toc371496773]Updating to CSPro 6.3 from earlier versions of CSPro
If you have an earlier version of CSPro installed on your computer, you can install CSPro 6.3 without affecting the older installation, and both versions can be run in parallel. Please notice, however, that version 6.3 is now the default program to open existing applications, and these are automatically converted to 6.3 format. You also have the option to remove the older version of CSPro from your computer if you are no longer using it as this will simplify opening CSPro applications.
[bookmark: _Toc371496774][bookmark: _Toc290901874][bookmark: _Toc295805580][bookmark: _Toc297832148][bookmark: _Toc322947076][bookmark: _Toc327430241][bookmark: _Toc327431302]Uninstall CSPro
The following is based on a Windows 10 setup. Your steps may vary if using a different operating system. 
1. From the Start button on the taskbar, select All Apps –> Windows System–> Control Panel. 
Select Programs-> Programs and Features. 
From the list of currently installed programs, click on the version of CSPro you would like to uninstall (e.g. CSPro 6.2)
Click “Uninstall” at the top of the window.
At the prompt, click OK to confirm that you want remove the program. The uninstall program will remove all registry entries and CSPro system files (that is, all files within the CSPro folder, such as its Examples subfolder). It will not remove any applications or other files you have created. 
When the files are removed, the installation program indicates that the process is complete. Click Finish. 

[bookmark: _Toc328137431][bookmark: _Toc454464202]
III. MISP CSPro application
The MISP Process Evaluation toolkit consists of four questionnaires: a health facility assessment (HFA) and three key informant interviews (General, GBV, and HIV).  A CSPro data entry application exists for each questionnaire and can be adapted to country context.
In this section, we will guide you through the file hierarchy of the MISP CSPro application, and also explain what the different files are for.
[bookmark: _Toc454464203]Preparing to open the MISP CSPro application
Download the MISP CSPro zip file and unpack the file MISP.zip to the desktop. This creates the folder MISP, which contains four subfolders, one for each of the MISP CSPro applications.
[bookmark: _Toc454464204]The MISP CSPro files structure
The MISP file hierarchy
When unpacked, the file hierarchy of MISP is like this:
C:\MISP\HFA			The main application to start up the HFA is located here  
\Data				The raw data files for the HFA data entered
C:\MISP\KII-GBV			The main application to start up the KII-GBV is located here  
\Data				The raw data files for the KII-GBV data entered
C:\MISP\KII-General		The main application to start up KII-General interview is located here  
\Data				The raw data files for the KII-General data entered
C:\MISP\KII-HV			The main application to start up the KII-HIV is located here  
\Data				The raw data files for the KII-HIV data entered
When moving around in the hierarchy, you will see that there are many files. This is because CSPro generates many different kinds of files. An interviewer need not to know anything about the files or hierarchy as a shortcut to launch the data entry application is provided for them. As an administrator of the application, however, you need to know more. 
File types in CSPro
In each CSPro application folder, there are many files and a multitude of file types. The following is an overview of the different types of files of CSPro. It is highly recommended to configure Windows Explorer to show extensions for known file types. A folder with CSPro files becomes rather confusing without the extensions showing. To do this: Open Control panel, and in the upper right corner choose “View by small icons”. Then you can click on “File Explorer options”. Choose the tab “View”, and un-tick “Hide extensions for known file types” Then click OK.

	File name
	File Name
	Description

	MISP_HFA.dcf
	Data Dictionary File
	Each file manipulated by CSPro must be described by a data dictionary.  The data dictionary file contains information defining the layout of the data file, including levels, records, items, value sets, and values.

	MISP_HFA.ent
	Data Entry Application File
	The data entry application file is the master file for the data entry application.  This file specifies all other files contained in the application, along with other information.

	MISP_HFA.ent.apc
	Logic File
	The logic file contains all the CSPro language statements which control the application.  There is one logic file associated with each application.

	MISP_HFA.ent.mgf
	Messages File
	The message file is a text file where you can store message text and an associated message number.  The message is displayed when an "errmsg" function with the message number is executed in a data entry application.  A message may contain parameters.

	MISP_HFA.ent.qsf
	Question File
	The question file contains information related to CAPI data entry applications.  Such information includes question text to appear on the screen with each field and when the operator presses the help key.

	MISP_HFA.fmf
	Form File
	The forms file contains information about forms, their fields, text, and rosters.  The forms file also contains the name of the associated data dictionary file.  The flow during data entry, that is, the order in which forms and fields are entered, is defined in the forms file, not in the data dictionary.

	MISP_HFA.pff
	Program Information File
	Program information files are used to run applications or tools in production mode.


File types in the data folder

	File name
	File Name
	Description

	MISP_HFA_data.dat
	Data file
	This is the flat file containing the actual data.

	MISP_HFA_data.dat.idx
	Data file index
	The data file index is a binary file that contains an index of case ids used by the CSPro data entry application to insure that each case has a unique set of case ids.

	MISP_HFA_data.dat.log
	Log file
	Operator statistics

	MISP_HFA_data.dat.lst
	Listing File
	Listing of data entry activity for each data file

	MISP_HFA_data.dat.not
	Notes file
	The notes file is a text file that contains all notes processed by the data entry application.

	MISP_HFA_data.dat.sts
	Status File
	Status of the data – whether the record is partially saved and/or verified.



[bookmark: _Toc328137436]

[bookmark: _Toc454464205]IV. Getting to know CSPro
[bookmark: _Toc454464206]Start CSPro and open a MISP application
Now you are ready to start a MISP application using CSPro.  For this example, we will be using the HFA application and the same steps apply for the KII applications if you would like to explore one of those instead.
1. Double-click on the desktop’s CSPro 6.3 icon or select All Programs -> CSPro 6.3-> CSPro 6.3  from the start menu
Select Open an existing application and double click on …other files to browse to the MISP_HFA.ent file. 
[image: ]
Alternatively, you can double click on the MISP_HFA.ent file.
The Identification information page of the MISP-HFA data entry application opens. The screen is subdivided into two parts: the left part displays a files tree; the right part corresponds to the application.
[image: ]

[bookmark: _Toc454464207]Explore the data entry application
[bookmark: _Toc371496790]The workspace
The CSPro workspace is divided into two parts: the left is reserved to display file trees; and the right window is reserved to display the actual application.
[image: ]Window
Trees

Workspace


[bookmark: _Toc371496791]Trees
Trees are displayed in the left part of the screen and they present the relationship between the different files. 
There are three types of trees, corresponding to the three tabs at the bottom part of the left screen (See red outline): the Files tree (Files), the Dictionary tree (Dicts) and the Forms tree (Forms). 
· Files: The Files tree shows all the data entry applications that are open, and the files they contain. 
· Dicts: The Dictionary tree shows all the dictionaries the application is using, and their contents.
· Forms: The data entry forms tree shows all the forms for the opened application. When clicking on the plus sign in from of a form, the items of the given form is also shown.
One can navigate from one tree to the other by clicking on the tab of interest (marked with a red ring above). 
In the above picture, the actual names of each of the fields of the form is displayed in the tree (For instance ID1). This is sometimes helpful, but sometimes you need to know more about the field. To alternate between showing the name or the label of the items in the tree, click on View/Names in tree (or use Ctrl+T).
[bookmark: _Toc371496792]Window
The window on the right side of the screen allows you to modify the contents of a dictionary or a form. Each different window has different functions associated with it (different menu and toolbar). When opening an existing application, CSPro displays the first form of the application as default (as shown above). To see the workspace for the dictionary instead, click on the dictionary icon [image: ]above the workspace.
[bookmark: _Toc371496793]Toolbars
Menu toolbar
The menu bar includes features common to most Windows applications plus some that are unique to CSPro.
[image: ]

Data Dictionary toolbar 
The Data Dictionary toolbar is displayed across the top of the window, below the menu bar. It provides quick mouse access to many features used in the Data Dictionary. It is available whenever the right-hand screen is displaying dictionary items. If the right-hand screen is not displaying dictionary items, click on the dictionary icon [image: ] on the toolbar.  
[image: ]
The table below provides a description of the function of each icon in the data dictionary toolbar.
	Button
	Function

	[image: ]
	Create a new dictionary

	[image: ]
	Open a dictionary

	[image: ]
	Save a dictionary

	[image: ]
	Set up page margins and headings for printing

	[image: ]
	Preview contents of the dictionary

	[image: ]
	Print contents of the dictionary

	[image: ]
	Undo the last change to dictionary

	[image: ]
	Redo last undo

	[image: ]
	Cut the selected records, items, or values to the clipboard

	[image: ]
	Copy the selected records, items, or values to the clipboard

	[image: ]
	Paste the contents of the clipboard to the current position

	[image: ]
	Add levels, records, items, values sets, or values

	[image: ]
	Insert levels, records, items, values sets, or values

	[image: ]
	Delete levels, records, items, value sets, or values

	[image: ]
	Edit Notes for dictionary, level, record, item, value set, or value

	[image: ]
	Find a label or a name in the dictionary

	[image: ]
	Show the Layout window

	[image: ]
	Show last Dictionary window

	[image: ]
	Show last Forms window

	[image: ]
	Get Help



The Forms Designer toolbar 
The forms designer toolbar is displayed across the top of the window, immediately below the menu bar. The toolbar provides quick mouse access to many of the often-used features found in the Forms Designer. It is available whenever the right-hand screen is displaying forms. If the right-hand screen is not displaying forms items, click on the forms icon [image: ] on the toolbar.  
[image: ]
  The table below provides a description of the function of each icon in the forms designer toolbar.
	Button
	Function

	[image: ]
	Create a New application

	[image: ]
	Open an application

	[image: ]
	Save an application

	[image: ]
	Compile the logic (code) of your data entry application

	[image: ]
	Run the current data entry application (i.e., start-up CSEntry)

	[image: ]
	Undo the latest changes

	[image: ]
	Redo the latest changes

	[image: ]
	Cut the selected elements to the clipboard

	[image: ]
	Copy the selected elements to clipboard

	[image: ]
	Paste the contents of the clipboard to the form

	[image: ]
	Delete the currently selected item(s)

	[image: ]
	Find text in logic

	[image: ]
	Toggle between selecting item(s) or drawing boxes

	[image: ]
	View the forms

	[image: ]
	View the logic

	[image: ]
	View the CAPI question

	[image: ]
	Show last Dictionary window

	[image: ]
	Show last Forms window

	[image: ]
	Get Help




[bookmark: _Toc454464208]
V. Modifying the MISP application
The MISP CSPro data collection system has been designed to correspond to the MISP Process Evaluation paper questionnaires.  If country specific changes are made to the paper questionnaires, they will need to be reflected in the CSPro data entry application as well.  This section provides information on how to make basic edits to the MISP CSPro applications.
[bookmark: _Toc454464209]Modify a dictionary item
[bookmark: _Toc371496797]The CSPro dictionary contains one item for each question in the questionnaire.  If adaptations have been made to the paper questionnaire, such as the addition or deletion of a question, they must also be made to the CSPro dictionary and the forms in CSPro.
Add a dictionary item to a dictionary
1. Look at the tree on the left side of the screen and make sure dictionary is selected.  If not, click on the dictionary tab ([image: ]). The screen should look something like this:
[image: ]
Decide what record the new dictionary item belongs to (say B_FACILITY_SECURITY). In the tree view on the left side, all of the records are visible (one section in the paper questionnaire corresponds to one record in the tree view). Click the relevant record.
Look at the window on the right side of the screen and make sure dictionary items are showing.  If not click on the dictionary icon on the toolbar.
The screen should now look something like this:
[image: ]
We will be adding the following question to the CSPro dictionary:

	Number
	Question
	Result
	Skip

	XX_1
	On average, how many hours per day is this facility open? 

	4 HOURS OR LESS	1
5 TO 8 HOURS	2
9 TO 16 HOURS	3
17 TO 23 HOURS	4
24 HOURS	5
DON’T KNOW	99
	



In the right- hand window of CSPro, right click on the dictionary item below where you would like to add a dictionary item.  For this example. We want the new item after B13: Do facilities have a private secure exam room hence right click on item B13. Select add item. Now fill out the following fields. Use the tab key to move between columns.
· Item Label: A descriptive label which identifies this record.  For this example, use the full question text as the label (XX_1: On average, how many hours per day is this facility open?) 
· Item Name: The name given to this record for use in the CSPro language procedures.  For MISP, we will use the question number as the item name. For this example, we will use XX_1.
· Start: Indicates the starting position of the item within the record.  This box should automatically fill-in and does not need to be changed.
· Len: Indicates the length of the data item (i.e., the number of characters necessary to represent the values for the item).  This should be the same as the number of digits in the response code, in this example 2.
· Data type: Indicates the type of data (numeric or alphanumeric) that will be found in the item. For this example, the choice should be Numeric.
· Item type: Indicates whether the item is or is not subordinate to, or part of, another item.  If the item is part of another item, it is considered a "subitem".  If not, it is identified as an "item".  Identification items cannot have subitems.  For the MISP questionnaire, use the default option of Item.
· Occ: The number of times this item will repeat within the record. The default value is "1". Identification items cannot have multiple occurrences.  For the MISP questionnaire, use the default number, 1.
· Dec: The number of decimal places (if any) in the item. The default number of decimals is "0". Identification items cannot have decimals.  For the MISP questionnaire, use the default number, 0.
· Dec Char: This specifies whether the item should be stored in the data file with an explicit decimal character. This applies only to items or subitems which have been defined with the "Dec" property greater than zero (i.e., Dec >= 1).    For the MISP questionnaire, use the default option of No.
· Zero fill: This item property states whether the numeric data item should contain leading zeros or blanks. For the MISP questionnaire, use the default option of No.
When all fields are complete, click anywhere in the window to complete the item entry.  The result should be a new dictionary item that looks like the following:
[image: ]
Go to File -> Save or Ctrl+S to save your work thus far.
Note: When adding a new question, be sure to add a new question number.  Do not change the existing numbering scheme as this will result in extensive edits to the application.  Instead add a country specific question number to all new questions.





[bookmark: _Toc328137442][bookmark: _Toc371496798]Create a new value set
A value set contains the numeric responses that are given to each item, and are used to define ranges of valid values during data entry.    These should correspond to the response options and response codes provided in the paper version of the questionnaire.
To access the area where value sets can be edited in CSPro, click on the dictionary icon on the toolbar on top of the CSPro window. By clicking on the items within the records in the tree view, you will get access to the value sets.
[image: ]
We are going to add a value set to the previously added dictionary item “B13: Do facilities have a private secure exam room” – or XX_1
1. Make sure you have the dictionary view in the right part of the display of CSPro by clicking on the dictionary item on the toolbar.
Expand the B_FACILITY_SECURITY record (click on the plus sign in front of it), and click on the XX_1 item to highlight it.
[image: ]
Right click in the right window and select Add Value Set.
Press Enter to accept the default Value Set Label and Value Set Name. The cursor will drop to the line below into the Value Label column. Remember, the Value Set Label is a descriptive text label, and the Value Set Name identifies the item for use in CSPro procedures.
The Value label column corresponds to the descriptive text for a single value.  In the MISP questionnaire this is the text of a response's options. For example, a question that has "Yes" or "No" as pre-defined response options should have "Yes" and "No" as the Value labels. If the question response does not have a pre-defined answer, such as for "Number of beds", leave the Value label blank. The "From" and "To" columns define the range of possible values for that question's response. 
The "From" column is for the single value, or starting value of a range associated with the Value label.  The "To" column is for the upper limit of the range of values being defined. It must always be greater than the "From" value on the same line. Where only a single value is associated with the Value Label, the "To" value may be blank. 
For this example we will enter the following for the "Value Label" and "From" columns, leaving the "To" column empty.  
4 HOURS OR LESS	1
5 TO 8 HOURS	2
9 TO 16 HOURS	3
17 TO 23 HOURS	4
24 HOURS	5
In addition we will add a value label for MISSING with a from value of 77 and under the column Special click on “Missing”.  This will allow the data entry personnel to identify any missing responses in the paper questionnaire as they are entering data electronically.
Your screen should look like the following after entering the value set:
[image: ]
[bookmark: _Toc371496799]Go to File -> Save or Ctrl+S to save your work thus far.
[bookmark: _Toc328137443][bookmark: _Toc371496805]Edit an existing value set
We want to add a value “99 – do not know” to the value set just created above.
1. Make sure the dictionary view is displayed. If not: click on the dictionary item on the toolbar of CSPro.
Expand the B_FACILITY_SECURITY record and click on the item XX_1 to highlight it.
Right click somewhere on the value set, and choose “Add value” (This will add the value at the end of the value set. If you want it in somewhere in the middle right click on the item under where you want it, and choose “insert value”)
Enter the text “Do not know” in the Value label field, and “99” in the From field.  Your screen should look like the following after entering the value set:
[image: ]
Go to File -> Save or Ctrl+S to save your work thus far.

If you want to change either the label or the value of an existing value in the value set: Right click on the value, and choose “Modify value”. Enter either the new label or the new value.
Add a newly created dictionary item to the form
After adding a dictionary item to the dictionary, it must then be added to the form. When opening the form (click on the form icon [image: ] on the toolbar), you will see that the new item is not added to the form. The next step is to add the item to the form.
1. Make sure you have the form visible on the right side of the CSPro window, and the dictionary in the tree view on the left (Click on the dictionary item on the bottom left part of the screen). In the tree view, it is easy to see what elements that have not been used in the form, as they have the icon marked turquoise (see the yellow highlight below).
[image: ]
Use the mouse to drag the item from the dictionary tree on to the forms canvas and place it where you want it.  It should appear in the same order as is listed in the dictionary.  For this example, we will place item XX_1 at the end of the form.
Right click on the response box for the new item and select field properties. Click on the button next to capture type and change from text box to drop down.  The click ok on the open screens.
[image: ]
The order of the questions when the application is running is the same as the order of the items displayed in the forms tree (click on the forms tab in the lower left part of CSPro):
[image: ]
Hence the new item is going to be asked at the very end of this section. For this example, this is where we want the new question to be asked.  If this question was placed in the middle of the form, it will need to be placed in the proper order in the forms tree.  To do this, grab the question with the mouse in the tree view, and drag it up to the right place in the tree.
Go to File -> Save or Ctrl+S to save your work thus far.
[bookmark: _Toc327431316][bookmark: _Toc328137440][bookmark: _Toc454464210]Delete a dictionary item
[bookmark: _Toc371496802]Delete the dictionary item from the dictionary
Say that we want to delete the item we just added – the XX_1 item in the section B_FACILITY_SECURITY. 
1. Look at the tree on the left side of the screen and make sure dictionary is selected.  If not, click on the dictionary tab.
Look at the window on the right side of the screen and make sure dictionary items are showing.  If not click on the dictionary icon on the toolbar.
Click on the B_FACILITY_SECURITY record to activate the dictionary items for this record in the right side window.
In the right-hand window, right click on the dictionary item labelled “XX_1: On average, how many hours per day is this facility open?” (the name of the item, XX_1 is in the second column) and click on delete item.  The item has now been removed from the data dictionary.
[bookmark: _Toc371496803]Cleaning up the form after deleting a dictionary item
The item will automatically be removed from the form, but some cleaning up might be needed.
1. Click on the forms icon on the toolbar. CSPro will then give this message:

[image: ]

Click on Delete XX_1 from form and then ok.
Click on the forms icon on the toolbar to check how the form looks after the deletion. If necessary: Move the items in the forms to improve the appearance of the form.
The XX_1 item is going to be used as an example in the next section, so please exit CSPro without saving.
Note:  In addition, if you delete anything from the dictionary, you will have to delete any associated programming.  This will be discussed later on, but it is important to keep note of what has been deleted.




[bookmark: _Toc322947001][bookmark: _Toc328137448][bookmark: _Ref371420604][bookmark: _Toc454464211]Modify logic
The CSPro language lets you write programming logic for your Data Entry applications. In Data Entry applications you can write logic to control and check the keying operation as it progresses.  CSPro logic consists of a collection of events defined as procedures. Each procedure performs the operations you specify using CSPro statements and functions written in the CSPro Language.
[bookmark: _Toc328137449]Logic has already been programmed into the CSPro application for the core MISP questionnaires.  If you have made changes to the core questionnaire, you may also have to make changes to the logic.  These changes will be specific to the questions changed.  Below are several examples of how to change the questionnaire logic.
[bookmark: _Toc371496807]Skip pattern
For this example, we will insert logic into the data entry application for the question B10. In question B10 we ask if the facility has latrines, and in question B11 and B12 we ask for additional details about the latrines. The latter questions should only be asked to the facilities that answered yes to the first question, hence we want to skip B11 and B12 if the answer to question B10 is no. 
1. Open the MISP_HFA file.
Look at the tree on the left side of the screen and make sure forms is selected.  If not, click on the forms tab.
Look at the window on the right side of the screen and make sure a form is showing.  If not click on the forms icon on the toolbar.
Click on the logic icon  [image: ] on the toolbar, or select View/View Logic from the main menu (or press Ctrl+L). 
[image: ]
Go to View menu and select Names in tree (or press Ctrl+T) to show names instead of labels in the forms tree. You can toggle between names and labels at any time to make sure that you are working with the correct items.
Click on B10 in the Forms tree. The frame on the right hand side of the screen should show "PROC B10" at the top. Note that "PROC" is short for procedure and B10 is the item name corresponding to the question which asks for the type of the facility.  We put our logic in the procedure for B10 because we want it to execute immediately after the operator keys this field. 
In the text editor, at the top of the logic view, type in the logic exactly as you see it below (the first line reading "PROC B10 " will already be displayed - do not repeat this text):
PROC B10

 	if B10 = 1 then
 	      skip to B11;
	      else skip to B13;
	endif; 
(Notice the use of semi colons at the end of each statement except from the PROC statement in the beginning. A semi colon tells CSPro that the instruction is finished. In the example above, the instruction starting with “if” is not really finished until after “endif”, while the “skip to..” instruction is finished at the end of that line.)
This logic code in CSPro language states that if the response for item number B10 is 1 (“yes”), then continue on to the next question, B11.  Otherwise, skip to question B13.
Your screen should look like this:
[image: ]
Go to File -> Save or Ctrl+S to save your work thus far.
A note about programming skip patterns: if the logic is typed in directly after the PROC statement, the default is that the logic will be applied AFTER the question is answered.  If you would like the logic to be applied BEFORE a question is answered, you must type preproc after the PROC statement.
[bookmark: _Toc328137450][bookmark: _Toc371496808]Logic to display error messages
To see all error messages – or create new ones, click on the “Message” tab on the bottom for the CSPro window:
[image: ]
Let us make a new error message for the field XX_1 that pops up if the interviewer chooses “Missing” (value 77)
1. Look at the tree on the left side of the screen and make sure forms is selected.  If not, click on the forms tab.
Look at the window on the right side of the screen and make sure a form is showing.  If not click on the forms icon on the toolbar.
Click on the logic icon  [image: ] on the toolbar, or select View/View Logic from the main menu (or press Ctrl+L). 
[image: ]
Click on XX_1 in the Forms tree. The frame on the right hand side of the screen should show "PROC XX_1" at the top. Put the logic in the procedure for XX_1 because we want it to execute immediately after the operator enters a response value.
In the text editor, at the top of the logic view, type in the logic exactly as you see it below (the first line reading "PROC XX_1" will already be displayed - do not repeat this text):

 		 	PROC XX_1
 	 			if XX_1 = 77 then
		 			errmsg(5);
		 			reenter XX_1;
	 		endif;

This logic code in CSPro language states that if the response for item number XX_1 is 77, an error message having the message number 5 will be displayed and the cursor will be placed back into the XX_1 response field so that the data entry personnel can re-enter the field.
The error message must also be entered in the message field: Click on the message tab, and type:

5   Please check again whether the response is Missing

The screen should look like this:
[image: ]
Go to File -> Save or Ctrl+S to save your work thus far.

[bookmark: _Toc328137451][bookmark: _Toc371496809]Compile logic
In the previous two steps, logic has been entered in CSPro language. Like all procedural languages, the system must check these to make sure there are no syntax errors. This is called "compiling". Once all logic changes have been entered, the CSPro application must be compiled.  To do this, use the following steps:
1. Click on MISP_HFA_FF at the very top in the Forms tree to show all the CSPro logic.
Compile the logic by clicking [image: ] on the toolbar, or select File/Compile from the main menu (or press Ctrl+K,). 
[image: ]
If you typed the logic correctly, you will see Compile Successful in the Compiler Output under the logic. 
If you see a dialog box that says Compile Failed, you have typed something incorrectly. A red circle will appear in the margin indicating the approximate location of the error. The Compiler Output tab at the bottom of the screen will show you an error message to help you determine the error. Check very carefully to make sure you typed in exactly what was shown in the previous tasks. 
The screen should look like this:
[image: ]
Go to File -> Save or Ctrl+S to save your work thus far.
Test the logic by running the application and select 77 in the field XX_1. The following error message should be displayed:
[image: ]
Also check if the skip in the question B10 works: Select “2 No” when answering. The questions B11 and B12 should now be skipped and yellow in color, while the cursor is now at B13:
[image: ]
When you are finished testing the logic, press the cross at the top left corner to quit the application. If you are at the beginning of a case or have not made any changes, the session will end immediately. If you have started, but not completed entry/modification/verification of a case, the following choices will be available.
· Partial Save: Partially save the changes you have made so far and remember the field you are on, so you can complete the work later.
·  Finish: Finish the data entry and save the modifications you have made. Available only in Modify mode.
·  Discard: Discard all the changes you have made since you opened this data entry application. Always available.
·  Cancel: Cancel this operation and return to entering the data. Always available.
For this example, we will select discard.
[bookmark: _Toc322947002][bookmark: _Toc328137453]

[bookmark: _Toc454464212]VI. Run the data entry application
[bookmark: _Toc328137454][bookmark: _Toc454464213]Check the settings
Before deploying the data entry application to all computers for data entry, use the following steps to ensure the correct settings are selected.
1. Open the MISP_HFA.ent file.
Make sure the forms tab is active.  On the menu toolbar, select Options ->Data entry
The recommended settings for the MISP CSPro application are as below:
[image: ]
Type: Operator vs. System Controlled 
CSPro offers two distinct types of data entry applications. Your choice will determine certain behaviors at data entry time. Some special data entry keys will behave differently. 
· Operator controlled:  This is the default type of data entry application. This type generally allows more flexibility for the interviewer during data entry and is recommended for simple ad-hoc applications. Operator-controlled applications have the following features: 
· Some special data entry keys are active during data entry. 
· CSEntry will not keep track of the path. 
· "Not applicable" values will be allowed. 
· More appropriate to the heads-down methodology. 
· Operator can bypass logic in the application using special keys. 
· System controlled:  These applications generally place more restrictions on the data entry operator. This type is used for complex survey applications and is recommended for real time electronic data entry. System controlled applications have the following features: 
· Some special data entry keys are not active during data entry. 
· CSEntry will keep track of the path. 
· "Not applicable" values will not be allowed. 
· More appropriate to the heads-up methodology. 
· Logic in the application is strictly enforced; operator cannot bypass or override.
Ask for Operator ID
Checking this box will prompt the data entry operator to enter ID information such as name or initials before beginning data collection.
Confirm End of Case
Checking this box will prompt the operator to accept the case at the end of each case entered.
Partial save
CAPI applications can be developed so that they support partial save. This allows the interviewer save an incomplete questionnaire, and then return later to complete it. To select this option, check the box Allow Partial Save.
Note: When you reopen a partially saved questionnaire, CSPro will ask whether you would like to return to the last place that data was entered or start at the beginning. 
Show case tree
Checking this box will allow the operator to see a tree on the left showing each item in the case currently being added, modified, or verified and its value.
Require Enter Key
Checking this box will require the data entry personnel to press the enter key to move to the next question.  If this box is not checked, the cursor will automatically move to the next entry field when the current field is filled.
[bookmark: _Toc328137455][bookmark: _Toc371496818][bookmark: _Toc454464214]Review forms
Switch to the forms view to see how your questions are displayed by selecting Form from the View menu. In the Form view, you can see the questionnaire you have developed.  Review to ensure that the forms follow the MISP paper questionnaire forms.
[bookmark: _Toc454464215]Set up data entry computers
For each computer that will be used for data entry, copy the MISP folder to the computer.  It is suggested to place this folder in the Documents folder or another easily identifiable location, but not on the DESKTOP.  This will prevent data entry personnel from accidentally accessing the core CSPro application or data files.
Once the MISP folder has been copied, open each of the four CSPro application folders, right click on the file with the extension .pff, and select “Create shortcut”.  Drag the shortcut to the Desktop.  Data entry personnel will now be able to run each CSPro application from its associated shortcut on the desktop by double clicking on the icon.
[bookmark: _Toc454464216]Collect data
1. Your data entry application is now ready to run.  CSEntry is the name of the program that runs this application, allowing you to key in data. Start the application by double clicking on the MISP HFA.pff file which should be a shortcut on the desktop of all data collection devices.
You may be prompted to select the data file.  Find the folder MISP\HFA\Data and call the file MISP_HFA_data.dat.  If no data has been entered before a message will pop up asking if you would like to create the file.  Select “Yes”.
Enter the operator ID, generally the data entry personnel’s initials.
If no data has been entered before, a new form (case) opens.  You can now start filling in the Identification information.  The question number and text should appear on the form with a response box next to it.  For questions that have a value set, a pop-up window will appear.  Select your answer and click on the right arrow to move forward or press the ENTER button.
[image: ]
If data already exists, CSPro starts the data entry program like this:
[image: ]

and you can choose between modifying an existing case (by double clicking on the ID element in the case tree to the left) or add a new case by clicking on this icon: [image: ] (or type ctrl-A)

If something happens in the middle of a case so that it cannot be finished, stop data entry by pressing on the red X in the upper right corner of the window. You will then get this question:

[image: ]

Choose “Partial save” to save what you have done so far, while “Discard” does not save the data. “Cancel” takes you back to the data entry.
To partially save the file while you are still collecting data, go to File/Save partial case.
The following pop-up window appears. Click “Ok” to continue the data entry.
[image: ]
Remember to save regularly while filling in the case to avoid any data lost. The application is programmed to automatically save at the end of each section so that will serve as a back-up in case the program crashes for any reason.
To review or finish up a questionnaire not finished during the previous visit, start up the MISP_HFA.pff as in the previous paragraph:
[image: ]
In the left pane, there is a list of all the facilities visited so far. Choose the one you want to review by double clicking on the facility name.  You can then use the case tree on the left to navigate to a particular question you would like to select.  Double click on the question of interest in the tree to move the cursor to that data entry element.
Occasionally you may need to override a skip pattern or error message due to an incomplete or incorrect paper questionnaire.  For example, if “Other” is selected, you will be prompted to specify what the “other” is.  If this information has not been recorded in the questionnaire, there is nothing to write in this data entry field.  If you click enter without entering data, an error message will appear saying Please specify.  Press F8 to clear the error message.  Then, instead of pressing enter to get to the next question, go to the case tree on the left and double click on the next question you would like to enter data for.  This will enable you to bypass the built in logic requiring a response to the “If other, specify” question.


[bookmark: _Toc454464217]VII. Concatenate and review data
After the data has been captured electronically, the data files have to be moved to a single desktop or laptop computer for further processing.  Copying data files from the data entry personnel’s computers to a central computer is usually done by the data entry supervisor.
At the end of the data entry, the data entry supervisor copy the data file for each data entry application into a folder on a USB drive and transfer it to a central computer.  It is advisable to create a clearly labelled file system for transferring data.  For example, a folder can be created for each data entry operator with an identifying title and placed within a single MISP_FINALDATA folder such as the following:
MISP_TeamX_Date1
MISP_TeamX_Date2            MISP_FINALDATA
MISP_TeamX_Date3
This final data set should be transferred to the data manager/focal point at central level in charge of the compilation of the data from field collection. A back-up of all data files (final and stamped with dates) should preciously be saved as back-up and remain accessible during the cleaning and data processing phase.
When all data have been transferred, there should be only one final data folder enclosing all data files from all the field teams:
[bookmark: _Toc454464218]Concatenate data files
Once all the data files from all the data entry computers are collected, CSPro provides a concatenate tool to merge all the data files into a single file. To concatenate the data files:
1. Go to the start menu and select Programs -> CSPro 6.3 -> Concatenate data.  A window like the one below will open.

[image: ]

1. Click on the “Add” button, and navigate to the folder with all the data files. Choose the file in each folder that is called MISP_HFA.dta. 
1. For the output file, choose “Browse”. Again: Navigate to the MISP_FINALDATA folder, and provide the file name 1_MISP_HFA_RAWDATA.dta. 
1. Click on run to do the actual concatenation. A successful concatenation will provide the following message:
[image: ]
1. A report will also open in a text viewer describing the process that has just been completed.  You can close this window and close the CSPro Concatenation tool.
1. Browse to MISP_FINALDATA folder and make sure the file 1_MISP_HFA_RAWDATA.dta is in the folder.
1. Repeat steps 1-6 for each MISP application (KKI-General, KII-GBV, and KII-HIV).  When complete you should have four final concatenated data sets.
[bookmark: _Toc454464219]Check concatenated data file for duplicate cases
In order to open and edit the 1_MISP_HFA_RAWDATA.dta file using the data entry application, there must not be any duplicate cases in the date file (cases where ALL of the ID items are exactly the same).  The CSPro Index Files tool will identify and duplicate cases.  To run the Index Files tool:
1. Go to the start menu and select Programs -> CSPro 6.3 -> Index Files.  A window like the one below will open.
[image: ]
1. Under dictionary, browse to MISP\HFA and select MISP_HFA.dcf.
1. Under Input file, browse to MISP_FINALDATA and select the 1_MISP_HFA_RAWDATA.dta file.
1. Make sure the circle next to “Output information to list file only” is selected.  This will create a report of any duplicate cases in the data file so that they can be reconciled.
1. Click on run.  Read the report and if any duplicate cases are identified they will need to be rectified in the original data set (before concatenation) then the data should be re-concatenated to create a final data set without any duplicate cases.
1. Repeat steps 1-5 for each MISP application (KKI-General, KII-GBV, and KII-HIV).
[bookmark: _Toc454464220]Open the concatenated data set using the data entry application
Now that the data files have been merged, you may want to open the final merged dataset in CSPro to review the data.
1. Browse to the MISP_HFA folder and double click on the MISP_HFA.pff file.
1. In the menu bar, go to File -> Open data file.  Under input data file select MISP_FINALDATA\1_MISP_HFA_RAWDATA and click ok.  The data file should open and all of the recorded cases should be listed in the tree on the left.
1. In the menu bar, go to View -> Cases in sort order to sort the cases numerically/alphabetically which will make it easier to search and review cases.
[bookmark: _Toc454464221]Review cases
Once the dataset is complete, each you may review the data in each case and edit as required.
1. To review and edit information for a case, double click on the record of interest in the right side tree.  The record should open in the left window and you can use the tree on the right to scroll to the question of interest.
1. Double click on the question of interest to take the cursor to the data entry location for that item.  Change the data entry to the correct response.
Now click on the stop icon [image: ] in the tool bar to stop editing.  The following box will pop up, select finish to save your edits.
[image: ]
[bookmark: _Toc454464222]Delete a case
Occasionally a case will be stored by accident that contains no data or a duplicate case will be identified.  These cases should be removed from the data set.
To delete the case, open the CSPro data entry application and the concatenated data file (e.g. 1_MISP_HFA_RAWDATA.dta). In the left pane, right click on the record that is to be deleted, and choose “delete”.  Please note, once a record has been deleted it cannot be restored without reverting to the original data file so please proceed with caution.
[bookmark: _Toc454464223][bookmark: _Toc297705907][bookmark: _Toc297832172][bookmark: _Toc322947021][bookmark: _Toc322947134]Dependent verification
Dependent verification is used to check that the electronic data are consistent with the responses in the paper version of the questionnaire.  When you verify a case, you key the case a second time as if you were in Add mode. Even though there is already data in the data file, CSEntry does not show this to you. All fields on the current form start out blank. Each time you key a field, the system compares the value you keyed with the value in the data file. If these two values match, you move to the next field. If the values do not match, you get a message telling you there is a discrepancy. When this happens, simply rekey the field. One of the following situations will occur: 
· The second value you key matches the value in the original data entry. The system assumes your first value is in error and moves to the next field. There will be no change to the data file for this field. 
· The second value you key matches the first value you keyed, but not the value in the original data entry. The system assumes the value in the original data entry is in error and moves to the next field. The new value, which you keyed twice, will replace the original value in the data file. 
· The second value you key matches neither the value in the data file nor the first value you keyed. The system will throw away the first value you keyed, show you the mismatch message and wait for you to rekey the field again. 
[bookmark: _Toc322947135]To begin verifying cases 
Press Ctrl+V; or from the Mode menu, select Verify case; or click on the toolbar to begin verifying cases from the beginning of the data file or where you left off verifying. This will begin a new Verify mode session. CSEntry keeps track of the last case that was verified, and positions you automatically to the next case to verify. If you did not complete verifying the last case, there will be a partially verified case in the data file marked with in the file tree. When you begin verification, you will be asked whether you want to begin verification where you left off within the case. You cannot verify cases if there are partially added or partially modified cases in the file. You must finish these cases before you can resume verification. You may verify as many cases as you like until you reach the end of the data file. 

[bookmark: _Toc322947136]Show Fields 
Sometimes you need to see the values in the data file on the screen. This is particularly useful if you are unsure which case you are verifying or exactly where in the case you are. You can use the Ctrl+F2 key to do this. When you press the Ctrl+F2 key you will see the values for all the fields on the current form. You must press Ctrl+F2 again to resume verifying.



[bookmark: _Toc454464224]VIII. Export data
CSPro has a built-in Export Data application that allows you to quickly and easily export data in a variety of formats. The exported data can then be imported into different software programs depending on your needs. 
The CSPro export function supports export to the following file formats:
· Tab delimited (.txt)
· Comma delimited (.csv)
· Semicolon delimited (.csv)
· CSPro (.dat, .dcf)
· SPSS (.dat, .sps)
· SAS (.dat, .sas)
· STATA (.dat, .dct, .do)
· R (.dat, .R)

Please use the steps below to export the data:
[bookmark: _Toc454464225]Open the CSPro export data application
1. On your computer, press the Start button and navigate to the CSPro Export Data application. This will most likely be located in Programs -> CSPro6.3 -> Export data.
The first screen in the CSPro Data Export application will ask you for the Data Dictionary File. Navigate to the MISP\HFA folder, select the MISP_HFA.dcf file, and click Open.
[bookmark: _Toc454464226]Select items for export
1. The panel on the left should now display the data dictionary's records and items in a selectable dictionary tree. From this dictionary tree you can select the data you would like to export. We will be exporting all of the data.  You can check the top box next to the dictionary icon to select all the items.  Your screen should look like this:
[image: ]
This screen will also display various export options, such as the export format, how many files you would like the application to create, and whether you want to include XML Metadata. We will keep the default options for everything except the Export Format.  
In the Export options section, select the format you would like to export to.  For exporting to Excel it is recommended to select Tab delimited (txt).  Alternatively, you can select to export to a particular statistical analysis software package file format.
Once you are ready to export the data, select Run from the File menu. 
The next screen will ask you to select the data file you would like to export. Please browse to the MISP_FINALDATA folder, select the data file of interest (e.g. 1_MISP_HFA_RAWDATA.dta), and click Open.
CSPro will then ask you to specify the name of the exported file.  Give this file a name of your choosing and select the location where you would like it to save. Press Save. 
You have now successfully exported data from CSPro.  Open the exported file to ensure the data has properly exported. Note: If you exported the data to STATA, the export creates three files: .dat, .dct, and .do.  In order to create the STATA dataset you need to open STATA, click on File -> Do and navigate to the .do file created in the data export process.  This will read in the .dat and .dct files to load the data and all value set labels.  Once this is complete click on File -> Save to save the dataset at a .dta (STATA file format).
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